lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christine Poerschke (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-12939) standardise test class naming
Date Tue, 30 Oct 2018 21:04:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-12939?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16669330#comment-16669330
] 

Christine Poerschke commented on SOLR-12939:
--------------------------------------------

bq. ... the Test suffix rather than prefix. ...

I have no strong views either way. Instead of choosing one or the other a hybrid solution
could also be to permit both but to enforce that within a given directory/sub-package/package
there is consistency.

Illustrative SOLR-12939.02.patch patch to follow on how {{ant validate-source-patterns}} (which
runs as part of {{ant precommit}}) could incrementally enforce that.

> standardise test class naming
> -----------------------------
>
>                 Key: SOLR-12939
>                 URL: https://issues.apache.org/jira/browse/SOLR-12939
>             Project: Solr
>          Issue Type: Test
>            Reporter: Christine Poerschke
>            Priority: Major
>         Attachments: SOLR-12939.01.patch
>
>
> This was mentioned and proposed on the dev mailing list. Starting this ticket here to
start to make it happen?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message