lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomás Fernández Löbbe (JIRA) <j...@apache.org>
Subject [jira] [Commented] (SOLR-12373) DocBasedVersionConstraintsProcessor doesn't work when schema has required fields
Date Tue, 15 Jan 2019 23:58:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-12373?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16743473#comment-16743473
] 

Tomás Fernández Löbbe commented on SOLR-12373:
----------------------------------------------

[~hossman], let me know if you have any thoughts on the latest patch. I think it addresses
your comments.

> DocBasedVersionConstraintsProcessor doesn't work when schema has required fields
> --------------------------------------------------------------------------------
>
>                 Key: SOLR-12373
>                 URL: https://issues.apache.org/jira/browse/SOLR-12373
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>            Reporter: Tomás Fernández Löbbe
>            Assignee: Tomás Fernández Löbbe
>            Priority: Minor
>         Attachments: SOLR-12373.patch, SOLR-12373.patch, SOLR-12373.patch
>
>
> DocBasedVersionConstraintsProcessor creates tombstones when processing a delete by id.
Those tombstones only have id (or whatever the unique key name is) and version field(s), however,
if the schema defines some required fields, adding the tombstone will fail.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message