lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-8346) Upgrade Zookeeper to version 3.5.5
Date Thu, 30 May 2019 04:54:01 GMT

    [ https://issues.apache.org/jira/browse/SOLR-8346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16851519#comment-16851519
] 

Erick Erickson commented on SOLR-8346:
--------------------------------------

[~janhoy] Or anybody else who likes the UI.... The new ZooKeeper 3.5.5 apparently requires
you whitelist all allowable "4 letter commands". This means that users will have to change
zoo.cfg to add a line like:

4lw.commands.whitelist=mntr,conf,ruok

for the admin UI ZkStatus to work. I'm putting that info into the ref guide and upgrade notes
for 8.2, but what I wondered is if we can point the users at this in the admin UI in the case
of an error in the pink error box that comes up?

I'm not quite clear on is how to communicate this unambiguously, but if you're game could
you raise a new JIRA that depends on this one and we can work on that after this is committed?

So far, the three four-letter commands above are the only ones I know are necessary, but there
may be others.

You can apply the patch for this JIRA and see the error if you're anxious. Note that the patch
(so far) doesn't have the doc updates.

Or if you can point me at the code (I'm a total JS noob) maybe I can do it in this JIRA.

Let me know...

> Upgrade Zookeeper to version 3.5.5
> ----------------------------------
>
>                 Key: SOLR-8346
>                 URL: https://issues.apache.org/jira/browse/SOLR-8346
>             Project: Solr
>          Issue Type: Task
>          Components: SolrCloud
>            Reporter: Jan H√łydahl
>            Assignee: Erick Erickson
>            Priority: Major
>              Labels: security, zookeeper
>         Attachments: SOLR-8346.patch, SOLR-8346.patch, SOLR-8346.patch, SOLR_8346.patch
>
>
> Investigate upgrading ZooKeeper to 3.5.x, once released. Primary motivation for this
is SSL support. --Currently a 3.5.4-beta is released (2018-05-17).-- Version 3.5.5 was released
2019-05-20



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message