lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-8346) Upgrade Zookeeper to version 3.5.5
Date Thu, 30 May 2019 16:14:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-8346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16852030#comment-16852030
] 

Erick Erickson commented on SOLR-8346:
--------------------------------------

[~janhoy]
bq. Is there a way to do authenticated/encrypted access to 4lw?

No idea. Sounds like a follow-on JIRA. So far the only thing that I've seen that the 4lw is
required for is the ZK Status in the Admin UI.

bq. Or have they released another http api for the same that we could switch to?

I wondered the same thing but haven't looked. Sounds like the same follow-on JIRA as above.

bq. Will new solr be allowed to run with ZK 3.4.x or do we plan to have dual support?

What Shawn said. Minimal testing so far works fine locally.

bq. Do you add the 4lw whitelist when running embedded zk?

Woke up this morning wondering about embedded and it works fine when I set the sysvar before
it's invoked. I chose to enable everything for embedded (*) on the theory that embedded isn't
a production recommendation. Easy to change though.

New patch momentarily with doc changes and embedded support.
Follow-on JIRA SOLR-13502

> Upgrade Zookeeper to version 3.5.5
> ----------------------------------
>
>                 Key: SOLR-8346
>                 URL: https://issues.apache.org/jira/browse/SOLR-8346
>             Project: Solr
>          Issue Type: Task
>          Components: SolrCloud
>            Reporter: Jan H√łydahl
>            Assignee: Erick Erickson
>            Priority: Major
>              Labels: security, zookeeper
>         Attachments: SOLR-8346.patch, SOLR-8346.patch, SOLR-8346.patch, SOLR_8346.patch
>
>
> Investigate upgrading ZooKeeper to 3.5.x, once released. Primary motivation for this
is SSL support. --Currently a 3.5.4-beta is released (2018-05-17).-- Version 3.5.5 was released
2019-05-20



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message