lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From digy digy <digyd...@gmail.com>
Subject Re: A problem of searching word "3D" with Lucene.net
Date Wed, 27 Jan 2010 10:22:27 GMT
If you index the string "3d model" using CLucene and use Luke,  you will see
that there are 3 terms in the index "3" , "d" and "model"
(it has to be "3d" and "model").
So, the problem is due to the incompatible StandardAnalyzer of CLucene.

DIGY.

On Wed, Jan 27, 2010 at 2:45 AM, ruanqizhen <ruanqizhen@gmail.com> wrote:

>
> I didn't try Luke.  But I tried CLucene for searching.   CLucene can return
> results for 3D.  So, this could be Lucene.net problem only.
>
>
> Shashi Kant-2 wrote:
> >
> > Have you tried querying the index using Luke? Check which analyzer you
> > used....
> >
> > On Mon, Jan 25, 2010 at 8:25 PM, ruanqizhen <ruanqizhen@gmail.com>
> wrote:
> >>
> >> Hi All,
> >>
> >> I have created an index file with CLucene.  I'm now using Luenen.net
> >> 2.3.2
> >> to query the index.  While searching key word "3D", it returns 0
> results.
> >> But my target file do have includes words like "3D model".
> >> If I search a pure numeric, it do return correct results.
> >>
> >> Anyone knows how to search "3D"?
> >>
> >> Thanks a lot!
> >> Qizhen
> >> --
> >> View this message in context:
> >>
> http://old.nabble.com/A-problem-of-searching-word-%223D%22-with-Lucene.net-tp27316636p27316636.html
> >> Sent from the Lucene - General mailing list archive at Nabble.com.
> >>
> >>
> >
> >
>
> --
> View this message in context:
> http://old.nabble.com/A-problem-of-searching-word-%223D%22-with-Lucene.net-tp27316636p27332439.html
> Sent from the Lucene - General mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message