lucene-java-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Lucene-java Wiki] Trivial Update of "MakingApiConsistent" by ivanGS
Date Sun, 16 Nov 2008 18:33:25 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Lucene-java Wiki" for change notification.

The following page has been changed by ivanGS:
http://wiki.apache.org/jakarta-lucene/MakingApiConsistent

------------------------------------------------------------------------------
  
   * 3) Examine, which components would be affected by possible refactoring
  
-  * 4) Propose patch for refactoring
+  * 4) Propose patches for refactoring
  
  ----
  ----
@@ -57, +57 @@

  
    Boolean methods could use start with isSomething / setSomething
  
+ ==== Some methods don't follow standard Java naming guidelines ====
+ Example:
+   QueryParser:
+ 
+   ReInit(...), Term(...), TopLevel(...) - look to me like constructors!!!
+ 
+   enable_tracing(), disable_tracing() - oh my!!!
+ 
+ Why is it bad?
+   People shouldn't have to memorize, which method starts with capital letter, and which
doesn't.
+ 
+ Solution:
+   All such methods and fields MUST be renamed use Java's recomended naming scheme.
+ 
+   http://java.sun.com/docs/codeconv/html/CodeConventions.doc5.html#381
+ 
  ----
  === 2) Identify concrete inconsistencies including their occurrences ===
  
@@ -68, +84 @@

  TODO
  
  ----
- === 4) Propose patch for refactoring ===
+ === 4) Propose patches for refactoring ===
  
  TODO
  

Mime
View raw message