lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Garg Raman \(SDinc\)" <>
Subject Lucene wiht Database??
Date Wed, 15 Oct 2003 07:25:52 GMT
I am new to Lucene and want to use it in my web application. Our client will have very large
DB on PostGre and what we need is to use Lucene for search purpose. It should give us the
rank of search also.
My problem is I can't found the method on How to Integrate Lucene with a Database table. Please
give any advice. Thanks in Advance


Raman Garg
(Software Engg)
SmartData Enterprises

----- Original Message ----- 
From: "lhelper" <>
To: "Lucene Users List" <>
Sent: Wednesday, October 15, 2003 12:40 PM
Subject: A strange Error--IllegalAccessError: tried to access field

> Hi.
> I get a strange problem with my web application recentlly. The webapp runs under:
>   resin-2.1.10
>   j2sdk1.4.2_01
>   redhat linux 2.4.20
> I use a subclass of IndexSearcher, IndexOrderSearcher, search the index, and output the
result use a servlet. The webapp works fine the most time, but, about half a month ago, I
got the following error when I restart resin:
> 500 Servlet Exception
> java.lang.IllegalAccessError: tried to access field
> from class
>  at Source)
>  at
>  at<init>(
>  at
>  at
>  at Source)
>  at Source)
>  at com.chedong.weblucene.WebLuceneServlet.doGet(Unknown Source)
>  at javax.servlet.http.HttpServlet.service(
>  at javax.servlet.http.HttpServlet.service(
>  at com.caucho.server.http.FilterChainServlet.doFilter(
>  at com.caucho.http.filter.GzipFilter.doFilter(
>  at com.caucho.server.http.FilterChainFilter.doFilter(
>  at com.caucho.server.http.Invocation.service(
>  at com.caucho.server.http.CacheInvocation.service(
>  at com.caucho.server.http.RunnerRequest.handleRequest(
>  at com.caucho.server.http.RunnerRequest.handleConnection(
>  at
>  at
> But After the server rebooted, everything gets right again.
> I have suspected that all applications runing in just one JVM causes the Error, so I
separated the applications with multiple JVMs, but the problem remains. Can anybody give me
some clue about this Error?
> Thanks!
> lhelper
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message