lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <>
Subject Re: trouble with permissions?
Date Thu, 01 Feb 2007 22:19:33 GMT
Miles Efron wrote:

> You rule.  Swapping out the nightly build seems to have fixed the 
> problem... tried it on two problematic cases and both worked.


> For the record, I'm running mac os 10.4.8.

Uh-oh, I can't explain why you would hit these errors on OS X 10.4.8;
we have only seen these one Windows.

Are you sure switching to trunk has fixed it?  Lockless commits makes
Lucene "write once" so this works around a number of file system
"quirks".  Still it'd be good to get to your root cause.

Is the index stored on a remote (Windows CIFS) mount?  Or is it stored
on a local (Mac OS HFS+) drive?

> Do you know if the lockless commits will be included in the next stable 
> release?

Yes this will be included in 2.1 -- I think 2.1 will be released soon
(there's been discussions on the dev list to get the release process
started soon).


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message