lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miles Efron <>
Subject trouble with permissions?
Date Thu, 01 Feb 2007 21:12:10 GMT
i seem to be having a problem analogous to this one (no answer that i  

trouble is, i just put lucene on my new macbook pro and am having the  
problem that if i build a large index, i get an I/O error due to  
something like Cannot overwrite: /data/reuters/indexes/reuters/

same code worked fine on my previous machine (still running on a G4  
powerbook and a linux machine).  sometimes it has trouble writing the  
segments file instead...

has anyone seen and solved this problem?  thoughts on what might be  
behind it?


On Feb 1, 2007, at 2:57 PM, Peter Keegan wrote:

> I have discovered a serious bug in QueryParser. The following query:
> contents:sales && contents:marketing || contents:industrial &&
> contents:sales
> is parsed as:
> +contents:sales +contents:marketing +contents:industrial  
> +contents:sales
> The same parsed query occurs even with parenthesis:
> (contents:sales && contents:marketing) || (contents:industrial &&
> contents:sales)
> Is there any way around this bug?
> Thanks,
> Peter

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message