lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miles Efron <>
Subject Re: trouble with permissions?
Date Thu, 01 Feb 2007 23:21:12 GMT
I really don't know why os x could have induced those kinds of  
filesystem issues.  i assumed that since i had switched over to the  
intel architecture that perhaps something was going on with the  
JVM...everything involved in the process was mac; local filesystem, etc.

but i'm fairly sure that the trunk code has fixed the problem.  i ran  
two 'offending' bits of code and checked their results.  not only did  
they finish (quite a feat today), but they did so correctly.


On Feb 1, 2007, at 4:19 PM, Michael McCandless wrote:

> Miles Efron wrote:
>> You rule.  Swapping out the nightly build seems to have fixed the  
>> problem... tried it on two problematic cases and both worked.
> Phew!
>> For the record, I'm running mac os 10.4.8.
> Uh-oh, I can't explain why you would hit these errors on OS X 10.4.8;
> we have only seen these one Windows.
> Are you sure switching to trunk has fixed it?  Lockless commits makes
> Lucene "write once" so this works around a number of file system
> "quirks".  Still it'd be good to get to your root cause.
> Is the index stored on a remote (Windows CIFS) mount?  Or is it stored
> on a local (Mac OS HFS+) drive?
>> Do you know if the lockless commits will be included in the next  
>> stable release?
> Yes this will be included in 2.1 -- I think 2.1 will be released soon
> (there's been discussions on the dev list to get the release process
> started soon).
> Mike
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message