lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trejkaz <trej...@trypticon.org>
Subject Re: IndexUpgrader across multiple versions
Date Wed, 27 May 2015 01:27:12 GMT
On Tue, May 12, 2015 at 4:52 PM, Trejkaz <trejkaz@trypticon.org> wrote:
>         - If the int is negative
>             - If it's >= -8, then it's Lucene 2.x
>             - If it's <= -9, then it's Lucene 3.x
>
> Is anything amiss with this logic?

To answer what nobody else is answering (perhaps nobody knows),
something is amiss with it.

v2.9 uses version -9 (FORMAT_DIAGNOSTICS):
https://lucene.apache.org/core/2_9_4/fileformats.html

v3.0 also uses the same version number:
https://lucene.apache.org/core/3_0_3/fileformats.html#Segments File

So I guess if I see version -9, I have to read more stuff to figure
out which format it is. :/

TX

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message