lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Any compatiblity issue in the upgrade from Lucene Core 3.2.0 to Core 6.1.0?
Date Mon, 08 Aug 2016 03:37:01 GMT
Yes. Lucene only guarantees back-compatibility with
indexes for one major version. That is, a 4.x release can
read a 3.x Lucene index. But a 5.x will not read a 3.x.

So you have some options here:
1> re-index all your source in 6.x. This is probably easiest....
2> upgrade in stages, check out the IndexUpgradeTool.
Here's the doc for 4.x, which should the 3.x version.

I'll leave it to the people who know Lucene better than me
to opine about whether running the IndexUpgrader several
times in succession works well.

Best,
Erick

On Sun, Aug 7, 2016 at 8:16 PM, 郑文兴 <zhengwx@csdn.net> wrote:
> Dear all,
>
>
>
> Our project is still running on Lucene Core 3.2.0, which is a little too
> old. If we wanna upgrade the version from 3.2.0 to 6.1.0, is there any
> compatibility issue, which requires some special actions?
>
>
>
> Appreciated for your advice
>
>
>
> Regards, Wenxing
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message