lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Wu <Jason...@ihsmarkit.com>
Subject Lucene IndexSearcher PrefixQuery seach getting really slow after a while
Date Thu, 03 Nov 2016 20:06:32 GMT
Hi Team,

We are using lucene 4.8.1 to do some info searches every day for years. However, recently
we encounter some performance issues which greatly slow down the lucene search.

After application running for a while, we are facing below issues, which  IndexSearcher PrefixQuery
taking much longer time to search:

[cid:image002.png@01D235EC.3C063740]

Our cpu and memory are fine, no leak found:
[cid:image004.jpg@01D235EC.3C063740]


However, for the exactly same java instance we are running on another box,  for the same info
we are searching, it is very fast.

I/O, memory, CPUS are all fine on both boxes.

So, do you know any reasons can cause this performance issue?

Thank you,
J.W

________________________________

This e-mail, including accompanying communications and attachments, is strictly confidential
and only for the intended recipient. Any retention, use or disclosure not expressly authorised
by Markit is prohibited. This email is subject to all waivers and other terms at the following
link: http://www.markit.com/en/about/legal/email-disclaimer.page

Please visit http://www.markit.com/en/about/contact/contact-us.page for contact information
on our offices worldwide.

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message