lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James liu" <liuping.ja...@gmail.com>
Subject Re: wana use CJKAnalyzer
Date Thu, 21 Sep 2006 01:19:46 GMT
sorry,,it is wrong...

my schema.xml

<?xml version="1.0" ?>
<schema name="example" version="1.1">
  <types>
    <fieldtype name="text" class="solr.TextField">
      <analyzer class="org.apache.lucene.analysis.cjk.CJKAnalyzer"/>
    </fieldtype>
    <fieldtype name="integer" class="solr.IntField"/>
  </types>
  <fields>
    <field name="id" type="integer" indexed="true" stored="true"/>
    <field name="content" type="text" indexed="true" stored="true"/>
  </fields>
  <uniqueKey>id</uniqueKey>
  <defaultSearchField>content</defaultSearchField>
</schema>



在06-9-21,James liu <liuping.james@gmail.com> 写道:
>
> to mike:
>
> " Are you testing the same field to which you are adding the analyzer?
> I noticed in another mail that you added this to the "text_lu" field
> type--the solr example uses "text", as I recall."
>
> now my schema.xml:
> <?xml version="1.0" encoding="UTF-8"?>
> <add>
>   <doc>
>       <field name="id">111</field>
>     <field name="content">姓名是刘平</field>
>   </doc>
>   <doc>
>       <field name="id">112</field>
>     <field name="content">姓名是小王</field>
>   </doc>
>   <doc>
>       <field name="id">113</field>
>     <field name="content">老婆不在家</field>
>   </doc>
> </add>
>
> but i m failed..
>



-- 
regards
jl
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message