lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <otis_gospodne...@yahoo.com>
Subject Re: Solr 1.1 HTTP server stops responding
Date Fri, 27 Jul 2007 14:00:32 GMT
Hi David,

Have you ruled out your servlet container as the source of this bug?

Otis


----- Original Message ----
From: David Whalen <dwhalen@enr-corp.com>
To: solr-user@lucene.apache.org
Sent: Friday, July 27, 2007 3:06:42 PM
Subject: Solr 1.1 HTTP server stops responding

Hi All.

We're running Solr 1.1 and we're seeing intermittent cases where
Solr stops responding to HTTP requests.  It seems like the listener
on port 8983 just doesn't respond.

We stop and restart Solr and everything works fine for a few hours,
and then the problem returns.  We can't seem to point to any
single factor that would lead to this problem, and I'm hoping
to get some hints on how to diagnose it.

Here's what I can tell you now, and I can provide more info by request:

1) The query load (via /solr/select) isn't that high.  Maybe 20 or 30
requests per minute tops.

2) The insert load (via /solr/update) is very high.  We commit almost
500,000 documents per day.  We also trim out the same number however,
so the net number of documents should stay around 20 million.

3) We do see Out of Memory errors sometimes, especially when making
facet queries (which we do most of the time).

We think solr is great, and we want to keep using it, but the downtime
makes the product (and us) look bad, so we need to solve this soon.

Thanks in advance for your help!

DW




Mime
View raw message