lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason P. Weiss" <jwe...@ftdi.com>
Subject RE: solr and Oracle 10g App Server
Date Mon, 30 Jul 2007 16:22:05 GMT
I had some trouble getting the current production build (1.2.0) working
on 10gR3 (10.1.3.0.0).

I had to remove 3 bad characters off of the front of the web.xml file
and re-jar the WAR file.  It worked perfectly after that minor
modification.

Jason

-----Original Message-----
From: Chris Hostetter [mailto:hossman_lucene@fucit.org] 
Sent: Monday, July 30, 2007 2:13 AM
To: solr-user@lucene.apache.org
Subject: Re: solr and Oracle 10g App Server


i noticed this message while catching up on some mail backlog ... i
don't know anything baout Oracle's app server, but some creative
googling for the error message you cited suggests to me that "Failed in
uploading archive. Invalid archive file:" is a common error message
preamble anytime Oracle's app server hasa problem starting up a war ....
the "Start of root element expected" part of the message might be the
message from an exception from Solr relating to a config file -- or it
might relate to anoracle specific config file ... i have no idea.

here's a similar error someone incountered where a very similar message
refered to a problem with the "oracle-webservices.xml" file .... perhaps
htat file is not welformed on your system...

http://forums.oracle.com/forums/thread.jspa?messageID=1800964

...i'm not sure that anyone in the solr community can provide you much
help without some more detailed info about what kinds of errors you re
getting from the actual messages logged by Solr.

: I've tried to deploy the solr war file in Oracle 10G, but keep getting
: the following error:
:
: " Failed in uploading archive. Invalid archive file: Start of root
: element expected."



-Hoss


Mime
View raw message