lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Alheiros <Daniel.Alhei...@bbc.co.uk>
Subject Re: Problems running SOLR 1.2 - documents not being indexed properly
Date Tue, 10 Jul 2007 10:19:42 GMT
Hi Hoss

Yes, no error and that strange behaviour on the numbers shown by the admin
console. I'll try an see how to make my SOLR logging better, because so far
it's not that good.

Regards,
Daniel


On 9/7/07 19:16, "Chris Hostetter" <hossman_lucene@fucit.org> wrote:

> 
> : After I removed manually it worked correctly and I've restarted a few times
> : since the "lost lock" was there... Isn't that lock removal on start-up
> : optional?
> 
> it is, it's controlled by the...
>     <unlockOnStartup>false</unlockOnStartup>
> ...option in the mainIndex or indexDefaults section.
> 
> : >> The main problem to me is that instead of having some failure
> : >> logging or
> : >> console information about it I just had those misleading information.
> 
> are you sure you didn't get an error?
> 
> I just tested this out by touching the write.lock file in solr/data/index,
> then started the server up, and on any attempt to add a document i got
> this in the Solr logs...
> 
> SEVERE: org.apache.lucene.store.LockObtainFailedException: Lock obtain
> timed out: 
> SimpleFSLock@/home/chrish/svn/solr/example/solr/data/index/write.lock
> 
> ...and i got a status 500 HTTP response code to my client.
> 
> 
> 
> -Hoss
> 


http://www.bbc.co.uk/
This e-mail (and any attachments) is confidential and may contain personal views which are
not the views of the BBC unless specifically stated.
If you have received it in error, please delete it from your system.
Do not use, copy or disclose the information in any way nor act in reliance on it and notify
the sender immediately.
Please note that the BBC monitors e-mails sent or received.
Further communication will signify your consent to this.
					

Mime
View raw message