lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Runo <mr...@zappos.com>
Subject Re: Replication script file issues..
Date Fri, 20 Jul 2007 16:15:42 GMT
Just an FYI..

it seems that the generated scripts.conf file had DOS format  
newlines. Once I did :set fileformat=unix in VIM, all was well.  
Everything is working like a champ now, with no other changes aside  
from that.

+--------------------------------------------------------+
  | Matthew Runo
  | Zappos Development
  | mruno@zappos.com
  | 702-943-7833
+--------------------------------------------------------+


On Jul 19, 2007, at 11:24 PM, Jed Reynolds wrote:

> Matthew Runo wrote:
>> It seems that as soon as I get a commit, snapshooter goes wild.
>>
>> I have 1107 running instances of snapshooter right now..
>>
>
> I suspect you've got pathing and/or permissions issues.
>
> First try running snapshooter -v, and it will be louder. I've often  
> had to dig in deeper, tho.
>
> I'd kill them all off. Edit the snapshooter script and add "set -x"  
> to line two of the script and run it by hand. Make sure to run it  
> by hand as the user (which might be tomcat, I don't know your  
> setup) that would be running it from cron.
>
> It might be that you have disk performance issue, or two much data  
> to transfer in 5 minutes or whatever your cron period is set to. If  
> you've got multiple snapshooters hogging the master rsync at once,  
> you'll very likely run into some blockage.
>
>


Mime
View raw message