lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dudes dudes <akam...@hotmail.co.uk>
Subject matser /slave issue on solr
Date Thu, 04 Sep 2008 08:46:07 GMT

Hello All, 

I have taken the following steps to configure master and slave servers.... However, the slave
doesn't seem to sync with the master... 
Please let me know what I have done wrong ,,,

both are nightly version 2008-7-7 on ubuntu machine java 1.6

On the master machine:

1) the scripts.conf file .

user=
solr_hostname= localhost
solr_port= 8983
rsyncd_port= 18983
data_dir=
webapp_name= solr
master_host=
master_data_dir=
master_status_dir=

2) Indexed some docs

3) Then I issued the following commands..

./rsyncd-enable; rsyncd-start 
./snapshooter

On the slave machine:

1) the scripts.conf file

user=
solr_hostname=mastereserver.companyname.com
solr_port=8080 
rsyncd_port=18983
data_dir=
webapp_name=solr
master_host=localhost
master_data_dir=/root/masterSolr/apache-solr-nightly/example/solr/data/
master_status_dir=/root/masterSolr/apache-solr-nightly/example/solr/logs/clients/

2) Then the following commands are issued:

./snappuller -P 18983
./snapinstaller
./commit 



3) however on the stats.jsp it says numDocs=0 ( on the salve machine). 

thanks for your time and suggestions 
ak





_________________________________________________________________
Get all your favourite content with the slick new MSN Toolbar - FREE
http://clk.atdmt.com/UKM/go/111354027/direct/01/
Mime
View raw message