lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steffen B." <s.baumg...@fhtw-berlin.de>
Subject NPE in dataimport.DebugLogger.peekStack (DIH Development Console)
Date Tue, 02 Jun 2009 14:36:01 GMT

Hi,
I'm trying to debug my DI config on my Solr server and it constantly fails
with a NullPointerException:
Jun 2, 2009 4:20:46 PM org.apache.solr.handler.dataimport.DataImportHandler
processConfiguration
INFO: Processing configuration from solrconfig.xml: {config=dataconfig.xml}
Jun 2, 2009 4:20:46 PM org.apache.solr.handler.dataimport.DataImporter
loadDataConfig
INFO: Data Configuration loaded successfully
Jun 2, 2009 4:20:46 PM org.apache.solr.handler.dataimport.DataImporter
verifyWithSchema
INFO: id is a required field in SolrSchema . But not found in DataConfig
Jun 2, 2009 4:20:46 PM org.apache.solr.handler.dataimport.SolrWriter
readIndexerProperties
INFO: Read dataimport.properties
Jun 2, 2009 4:20:46 PM org.apache.solr.handler.dataimport.DataImporter
doFullImport
INFO: Starting Full Import
Jun 2, 2009 4:20:46 PM org.apache.solr.handler.dataimport.SolrWriter
readIndexerProperties
INFO: Read dataimport.properties
Jun 2, 2009 4:20:46 PM org.apache.solr.handler.dataimport.DataImporter
doFullImport
SEVERE: Full Import failed
java.lang.NullPointerException
        at
org.apache.solr.handler.dataimport.DebugLogger.peekStack(DebugLogger.java:78)
        at
org.apache.solr.handler.dataimport.DebugLogger.log(DebugLogger.java:98)
        at
org.apache.solr.handler.dataimport.SolrWriter.log(SolrWriter.java:248)
        at
org.apache.solr.handler.dataimport.DocBuilder.buildDocument(DocBuilder.java:304)
        at
org.apache.solr.handler.dataimport.DocBuilder.doFullDump(DocBuilder.java:224)
        at
org.apache.solr.handler.dataimport.DocBuilder.execute(DocBuilder.java:167)
        at
org.apache.solr.handler.dataimport.DataImporter.doFullImport(DataImporter.java:316)
        at
org.apache.solr.handler.dataimport.DataImporter.runCmd(DataImporter.java:376)
        at
org.apache.solr.handler.dataimport.DataImportHandler.handleRequestBody(DataImportHandler.java:187)
        at
org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:131)
        at org.apache.solr.core.SolrCore.execute(SolrCore.java:1328)
        at
org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:341)
        at
org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:244)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at
org.apache.catalina.valves.RequestFilterValve.process(RequestFilterValve.java:276)
        at
org.apache.catalina.valves.RemoteHostValve.invoke(RemoteHostValve.java:81)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at
org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:834)
        at
org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:640)
        at
org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1286)
        at java.lang.Thread.run(Thread.java:619)

Running a normal full-import works just fine, but whenever I try to run the
debugger, it gives me this error. I'm using the most recent Solr nightly
build (2009-06-01) and the method in question is:
private DebugInfo peekStack() {
    return debugStack.isEmpty() ? null : debugStack.peek();
}
I'm using a DI config that has been working fine in for several previous
builds, so that shouldn't be the problem... any ideas what the problem could
be?
Thanks in advance,
Steffen
-- 
View this message in context: http://www.nabble.com/NPE-in-dataimport.DebugLogger.peekStack-%28DIH-Development-Console%29-tp23833878p23833878.html
Sent from the Solr - User mailing list archive at Nabble.com.


Mime
View raw message