lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rupert Fiasco <rufia...@gmail.com>
Subject Re: Responses getting truncated
Date Fri, 28 Aug 2009 23:07:22 GMT
I deployed LucidWorks with my existing solrconfig / schema and
re-indexed my data into it and pushed it out to production, we'll see
how it stacks up over the weekend. Already queries that were breaking
on the prior Jetty/stock Solr setup are now working - but I have seen
it before where upon an initial re-index things work OK then a couple
of days later they break.

Keep y'all posted.

Thanks
-Rupert

On Fri, Aug 28, 2009 at 3:12 PM, Rupert Fiasco<rufiasco@gmail.com> wrote:
> Yes, I am hitting the Solr server directly (medsolr1.colo:9007)
>
> Versions / architectures:
>
> Jetty(6.1.3)
>
> ooga@medsolr1 ~ $ uname -a
> Linux medsolr1 2.6.18-xen-r12 #9 SMP Tue Mar 3 15:34:08 PST 2009
> x86_64 Intel(R) Xeon(R) CPU L5420 @ 2.50GHz GenuineIntel GNU/Linux
>
> ooga@medsolr1 ~ $ java -version
> java version "1.6.0_11"
> Java(TM) SE Runtime Environment (build 1.6.0_11-b03)
> Java HotSpot(TM) 64-Bit Server VM (build 11.0-b16, mixed mode)
>
>
> I was thinking of trying LucidWorks for Solr (1.3.02) x64 - worth a try.
>
> -Rupert
>
> On Fri, Aug 28, 2009 at 3:08 PM, Yonik Seeley<yseeley@gmail.com> wrote:
>> On Mon, Aug 24, 2009 at 6:30 PM, Rupert Fiasco<rufiasco@gmail.com> wrote:
>>> If I run these through curl on the command its
>>> truncated and if I run the search through the web-based admin panel
>>> then I get an XML parse error.
>>
>> Are you running curl directly against the solr server, or going
>> through a load balancer?  Cutting out the middle-men using curl was a
>> great idea - just make sure to go all the way.
>>
>> At first I thought it could possibly be a FastWriter bug (internal
>> Solr class), but that's only used on the TextWriter (JSON, Python,
>> Ruby) based formats, not on the original XML format.
>>
>> It really looks like you're hitting a lower-level IO buffering bug
>> (esp when you see a response starting off with the tail of another
>> response).  That doesn't look like it could be a Solr bug... but
>> rather smells like a thread safety bug in the servlet container.
>>
>> What type of machine are you running on?  What JVM?
>> You could try upgrading your version of Jetty, the JVM, or try
>> switching to Tomcat.
>>
>> -Yonik
>> http://www.lucidimagination.com
>>
>>
>>> This appears to have just started recently and the only thing we have
>>> done is change our indexer from a PHP one to a Java one, but
>>> functionally they are identical.
>>>
>>> Any thoughts? Thanks in advance.
>>>
>>> - Rupert
>>>
>>
>

Mime
View raw message