lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rperkowska <>
Subject Re: Using mincount with date facet in Solr 1.4
Date Tue, 13 Oct 2009 17:15:39 GMT

in my  ATs I'm observing a similar thing happening from time to time - in a
search that I perform I can see facet results that contain '0' both as keys
and values. But there is no possibility that zeros are valid values. When I
do a normal search, I don't see any indexed fields with zeros. What's more
weird is that when I run my facet test (using JMeter) in isolation,
everything works fine. It happens only when it's being run after other tests
(and other indexing). On the other hand it shouldn't be the case that other
indexing are influencing this test, as at the end of each test I'm deleting
indexed documents so before running the facet test an index is empty.

My facet test looks as follows:
1. Index group of documents
2. Perform search on facets
3. Remove documents from the index.

The results that I'm getting for an integer field 'year':


I'm indexing only values 1990-1999, so there certainly shouldn't be any '0'
as keys in the result set.
I'm suing Solrj 1.3.
Does it appear to be a Solr bug?


Aakash Dharmadhikari wrote:
> hi,
>   I am creating facets on a field of type
>   <field name="daysForFilter" type="date" indexed="true" stored="true"
> multiValued="true"/>
>   The field can contain any number of dates even 0. I am making a facet
> query on the field with following query parameters:
>   facet=true
>   But I was getting facets even with count 0. So I tried following
> combinations of mincount parameters, as none was specified in the
> wiki<>,
> for date faceting.
>   f.daysForFilter.facet.mincount=1
>   facet.mincount=1
>   But none of these work. Could anyone please let me know how I can do
> this?
> regards,
> aakash

View this message in context:
Sent from the Solr - User mailing list archive at

View raw message