lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giovanni Fernandez-Kincade <gfernandez-kinc...@capitaliq.com>
Subject RE: IndexWriter InfoStream in solrconfig not working
Date Wed, 07 Oct 2009 17:45:30 GMT
I had the same problem. I'd be very interested to know how to get this working...

-Gio.

-----Original Message-----
From: Burton-West, Tom [mailto:tburtonw@umich.edu] 
Sent: Wednesday, October 07, 2009 12:13 PM
To: solr-user@lucene.apache.org
Subject: IndexWriter InfoStream in solrconfig not working

Hello,

We are trying to debug an indexing/optimizing problem and have tried setting the infoStream
 file in solrconf.xml so that the SolrIndexWriter will write a log file.  Here is our setting:

<!--
         To aid in advanced debugging, you may turn on IndexWriter debug logging. Uncommenting
this and setting to true
         will set the file that the underlying Lucene IndexWriter will write its debug infostream
to.
        -->
    <infoStream file="/tmp/LuceneIndexWriterDebug.log">true</infoStream>

After making that change to solrconfig.xml, restarting Solr, we see a message in the tomcat
logs saying that the log is enabled:

build-2_log.2009-10-06.txt:INFO: IndexWriter infoStream debug log is enabled: /tmp/LuceneIndexWriterDebug.log

However, if we then run an optimize we can't see any log file being written.

I also looked at the patch for  http://issues.apache.org/jira/browse/SOLR-1145, but did not
see a unit test that I might try to run in our system.


Do others have this logging working successfully ?
Is there something else that needs to be set up?

Tom


Mime
View raw message