lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rohan rai <hiroha...@gmail.com>
Subject Re: DIH and EmbeddedSolr
Date Tue, 13 Oct 2009 05:46:50 GMT
Hey
Any reason why it may be happening ??

Regards
Rohan

On Sun, Oct 11, 2009 at 9:25 PM, rohan rai <hirohanin@gmail.com> wrote:

>
> Small data set..
> <?xml version="1.0" encoding="UTF-8" ?>
> <root>
> <test>
>     <id>11</id>
>     <name>11</name>
>     <type>11</type>
> </test>
> <test>
>     <id>22</id>
>     <name>22</name>
>     <type>22</type>
> </test>
> <test>
>     <id>33</id>
>     <name>33</name>
>     <type>33</type>
> </test>
> </root>
>
> data-config
> <dataConfig>
>     <dataSource type="FileDataSource"/>
>     <document>
>         <entity name="test" processor="XPathEntityProcessor"
>             forEach="/root/test/"
>             url="/home/test/test_data.xml"
>             >
>             <field column="id" name="id" xpath="/root/test/id"/>
>             <field column="name" name="name" xpath="/root/test/name"/>
>             <field column="type" name="type" xpath="/root/test/type"/>
>         </entity>
>     </document>
> </dataConfig>
>
> schema
> <?xml version="1.0" ?>
> <schema name="test" version="1.1">
>   <types>
>    <fieldtype name="string"  class="solr.StrField" sortMissingLast="true"
> omitNorms="true"/>
>   </types>
>
>  <fields>
>   <field name="id"      type="string"   indexed="true"  stored="true"
> multiValued="false" required="true"/>
>   <field name="type"    type="string"   indexed="true"  stored="true"
> multiValued="false" />
>   <field name="name"    type="string"   indexed="true"  stored="true"
> multiValued="false" />
>  </fields>
>
>  <uniqueKey>id</uniqueKey>
>
>  <defaultSearchField>name</defaultSearchField>
>
>  <solrQueryParser defaultOperator="OR"/>
> </schema>
>
> Sometime it creates sometimes it gives thread pool exception. It does not
> consistently creates the index.
>
> Regards
> Rohan
>
>
> On Sun, Oct 11, 2009 at 3:56 PM, Shalin Shekhar Mangar <
> shalinmangar@gmail.com> wrote:
>
>> On Sat, Oct 10, 2009 at 7:44 PM, rohan rai <hirohanin@gmail.com> wrote:
>>
>> > This is pretty unstable...anyone has any clue...Sometimes it even
>> creates
>> > index, sometimes it does not ??
>> >
>> >
>> Most DataImportHandler tests run Solr in an embedded-like mode and they
>> run
>> fine. Can you tell us which version of Solr are you using? Also, any data
>> which can help us reproduce the problem would be nice.
>>
>> --
>> Regards,
>> Shalin Shekhar Mangar.
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message