lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glock, Thomas" <thomas.gl...@pfizer.com>
Subject Solr under tomcat - UTF-8 issue
Date Sat, 24 Oct 2009 15:28:51 GMT

Hoping someone can help -

Problem: 
	Querying for non-english phrases such as Добавить do not return any results under
Tomcat but do work when using the Jetty example.  

	Both tomcat and jetty are being queried by the same custom (flash) client and both reference
the same solr/data/index.  

	I'm using an http POST rather than http GET to do the query to solr.  I believe the problem
must be in how tomcat is configured and had hoped the -Dfile.encoding=UTF-8 would solve it
- but no luck.  I've stopped started tomcat and deleted the work directory as well.

	Results are the same in both IE6 and Firefox and I've used both firebug and fiddler to view
the http request/responses.  It is consistent - jetty works, tomcat does not.

Environment:
	Tomcat 6 as a service on WinXP Professional 2002 sp 2 
	Tomcat Java properties -

	-Dcatalina.home=C:\Program Files\Apache Software Foundation\Tomcat 6.0
	-Dcatalina.base=C:\Program Files\Apache Software Foundation\Tomcat 6.0
	-Djava.endorsed.dirs=C:\Program Files\Apache Software Foundation\Tomcat 6.0\endorsed
	-Djava.io.tmpdir=C:\Program Files\Apache Software Foundation\Tomcat 6.0\temp
	-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
	-Djava.util.logging.config.file=C:\Program Files\Apache Software Foundation\Tomcat 6.0\conf\logging.properties
	-Dfile.encoding=UTF-8

Thanks in advance.
Tom Glock


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message