lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joel Nylund <jnyl...@yahoo.com>
Subject Re: weird behavior between 2 enviorments
Date Thu, 03 Dec 2009 16:00:51 GMT
same client, here are the debug results, something interesting is  
going on, I dont understand solr/lucene well enough to understand, see  
below

not working env (linux)

<response>
−
<lst name="responseHeader">
<int name="status">0</int>
<int name="QTime">2</int>
−
<lst name="params">
<str name="debugQuery">true</str>
<str name="q">countryName:"Bosnia and Herzegovina"</str>
</lst>
</lst>
<result name="response" numFound="0" start="0"/>
−
<lst name="debug">
<str name="rawquerystring">countryName:"Bosnia and Herzegovina"</str>
<str name="querystring">countryName:"Bosnia and Herzegovina"</str>
<str name="parsedquery">PhraseQuery(countryName:"bosnia herzegovina")</ 
str>
<str name="parsedquery_toString">countryName:"bosnia herzegovina"</str>
<lst name="explain"/>
<str name="QParser">LuceneQParser</str>
−
<lst name="timing">
<double name="time">2.0</double>
−
<lst name="prepare">
<double name="time">1.0</double>
−
<lst name="org.apache.solr.handler.component.QueryComponent">
<double name="time">1.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.FacetComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.MoreLikeThisComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.HighlightComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.StatsComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.DebugComponent">
<double name="time">0.0</double>
</lst>
</lst>
−
<lst name="process">
<double name="time">1.0</double>
−
<lst name="org.apache.solr.handler.component.QueryComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.FacetComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.MoreLikeThisComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.HighlightComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.StatsComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.DebugComponent">
<double name="time">0.0</double>
</lst>
</lst>
</lst>
</lst>
</response>




working env (osx)

<response>
−
<lst name="responseHeader">
<int name="status">0</int>
<int name="QTime">54</int>
−
<lst name="params">
<str name="q">countryName:"Bosnia and Herzegovina"</str>
<str name="debugQuery">true</str>
</lst>
</lst>
−
<result name="response" numFound="2" start="0">
−
<doc>
<str name="countryName">Bosnia and Herzegovina</str>
<str name="id">83964763</str>
</doc>
−
<doc>
<str name="countryName">Bosnia and Herzegovina</str>
<str name="id">96465437</str>
</doc>
</result>
−
<lst name="debug">
<str name="rawquerystring">countryName:"Bosnia and Herzegovina"</str>
<str name="querystring">countryName:"Bosnia and Herzegovina"</str>
<str name="parsedquery">PhraseQuery(countryName:"bosnia ?  
herzegovina")</str>
<str name="parsedquery_toString">countryName:"bosnia ? herzegovina"</ 
str>
−
<lst name="explain">
−
<str name="83964763">

15.619301 = fieldWeight(countryName:"bosnia herzegovina" in 260955),  
product of:
   1.0 = tf(phraseFreq=1.0)
   24.990881 = idf(countryName: bosnia=2 herzegovina=2)
   0.625 = fieldNorm(field=countryName, doc=260955)
</str>
−
<str name="96465437">

15.619301 = fieldWeight(countryName:"bosnia herzegovina" in 275091),  
product of:
   1.0 = tf(phraseFreq=1.0)
   24.990881 = idf(countryName: bosnia=2 herzegovina=2)
   0.625 = fieldNorm(field=countryName, doc=275091)
</str>
</lst>
<str name="QParser">LuceneQParser</str>
−
<lst name="timing">
<double name="time">53.0</double>
−
<lst name="prepare">
<double name="time">24.0</double>
−
<lst name="org.apache.solr.handler.component.QueryComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.FacetComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.MoreLikeThisComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.HighlightComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.StatsComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.DebugComponent">
<double name="time">0.0</double>
</lst>
</lst>
−
<lst name="process">
<double name="time">27.0</double>
−
<lst name="org.apache.solr.handler.component.QueryComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.FacetComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.MoreLikeThisComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.HighlightComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.StatsComponent">
<double name="time">0.0</double>
</lst>
−
<lst name="org.apache.solr.handler.component.DebugComponent">
<double name="time">27.0</double>
</lst>
</lst>
</lst>
</lst>
</response>


On Dec 3, 2009, at 10:20 AM, Yonik Seeley wrote:

> Are you querying both systems from the same browser / client?
> Try adding debugQuery=true and see of the query parses the same for
> both (could be the browser/client doing extra escaping or something).
>
> -Yonik
> http://www.lucidimagination.com
>
>
>
> On Thu, Dec 3, 2009 at 10:14 AM, Joel Nylund <jnylund@yahoo.com>  
> wrote:
>> I have 2 environments one works great for this query:
>>
>> my osx environment:
>>
>> http://localhost:8983/solr/select?q=countryName:%22Bosnia%20and%20Herzegovina%22
>> - returns 2 results
>>
>> my linux environment:
>>
>> http://localhost:8983/solr/select?q=countryName:%22Bosnia%20and%20Herzegovina%22
>> - returns 0 results
>>
>>
>> same configs, same index etc, both using solr 1.4, in linux env if  
>> I run
>> this query:
>>
>> /solr/select?q=id:96465437
>>
>> <response>
>> -
>> <lst name="responseHeader">
>> <int name="status">0</int>
>> <int name="QTime">1</int>
>> -
>> <lst name="params">
>> <str name="q">id:96465437</str>
>> </lst>
>> </lst>
>> -
>> <result name="response" numFound="1" start="0">
>> -
>> <doc>
>> ...
>> <str name="countryName">Bosnia and Herzegovina</str>
>> ....
>> </doc>
>> </result>
>> </response>
>>
>> So the records are in the index.....
>>
>> I checked the admin, they are indexed using the same type (text),  
>> and I
>> cannot see any differences.
>>
>> any idea why it works on one env and not the other? anything I can  
>> check in
>> admin to get to the bottom of this?
>>
>> thanks
>> Joel
>>
>>


Mime
View raw message