lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter 4U <pete...@hotmail.com>
Subject Facet query with special characters
Date Thu, 03 Dec 2009 13:29:45 GMT

Hello,
 
I've encountered some strange behaviour in Solr facet querying, and I've not been able to
find anything on this on the web.
Perhaps someone can shed some light on this?
 
The problem:
When performing a facet query where part of the value portion has a special character (a minus
sign in this case), the query returns zero results unless I put a wildcard (*) at the end.


 
Here is my query:
 
This produces zero 'numFound':
http://localhost:8983/solr/select/?wt=xml&indent=on&rows=20&q=((signature:3083
AND host:pds-comp.domain)) AND _time:[091119124039 TO 091203124039]&facet=true&facet.field=host&facet.field=sourcetype&facet.field=user&facet.field=signature
 
This produces 28 'numFound':
http://localhost:8983/solr/select/?wt=xml&indent=on&rows=20&q=((signature:3083
AND host:pds-comp.domain*)) AND _time:[091119124039 TO 091203124039]&facet=true&facet.field=host&facet.field=sourcetype&facet.field=user&facet.field=signature


(Note: all hit results are for <host>pds-comp.domain</host> - there are no other
characters in the resulting field values)


I've tried escaping the minus sign in various ways, encoding etc., but nothing seems to work.
Can anyone help?
 
Many thanks,
Peter

 		 	   		  
_________________________________________________________________
Add your Gmail and Yahoo! Mail email accounts into Hotmail - it's easy
http://clk.atdmt.com/UKM/go/186394592/direct/01/
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message