lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William Pierce" <evalsi...@hotmail.com>
Subject Re: Exception encountered during replication on slave....Any clues?
Date Tue, 08 Dec 2009 16:26:15 GMT
Hi, Noble:

When I hit the masterUrl from the slave box at

http://localhost:8080/postingsmaster/replication

I get the following xml response:

<?xml version="1.0" encoding="UTF-8" ?>
    - <response>
        - <lst name="responseHeader">
         <int name="status">0</int>
        <int name="QTime">0</int>
        </lst>
        <str name="status">OK</str>
         <str name="message">No command</str>
  </response>

And then when I look in the logs,  I see the exception that I mentioned. 
What exactly does this error mean that "replication is not available".    By 
the way, when I go to the admin url for the slave and click on replication, 
I see a screen with the master url listed (as above) and the word 
"unreachable" after it.    And, of course, the same exception shows up in 
the tomcat logs.

Thanks,

- Bill

--------------------------------------------------
From: "Noble Paul നോബിള്‍  नोब्ळ्" <noble.paul@corp.aol.com>
Sent: Monday, December 07, 2009 9:20 PM
To: <solr-user@lucene.apache.org>
Subject: Re: Exception encountered during replication on slave....Any clues?

> are you able to hit the
> http://localhost:8080/postingsmaster/replication using a browser from
> the slave box. if you are able to hit it what do you see?
>
>
> On Tue, Dec 8, 2009 at 3:42 AM, William Pierce <evalsinca@hotmail.com>
> wrote:
>> Just to make doubly sure,  per tck's suggestion,  I went in and
>> explicitly
>> added in the port in the masterurl so that it now reads:
>>
>> http://localhost:8080/postingsmaster/replication
>>
>> Still getting the same exception...
>>
>> I am running solr 1.4, on Ubuntu karmic, using tomcat 6 and Java 1.6.
>>
>> Thanks,
>>
>> - Bill
>>
>> --------------------------------------------------
>> From: "William Pierce" <evalsinca@hotmail.com>
>> Sent: Monday, December 07, 2009 2:03 PM
>> To: <solr-user@lucene.apache.org>
>> Subject: Re: Exception encountered during replication on slave....Any
>> clues?
>>
>>> tck,
>>>
>>> thanks for your quick response.  I am running on the default port
>>> (8080).
>>> If I copy that exact string given in the masterUrl and execute it in the
>>> browser I get a response from solr:
>>>
>>> <?xml version="1.0" encoding="UTF-8" ?>
>>> - <response>
>>> - <lst name="responseHeader">
>>>  <int name="status">0</int>
>>>  <int name="QTime">0</int>
>>>  </lst>
>>>  <str name="status">OK</str>
>>>  <str name="message">No command</str>
>>>  </response>
>>>
>>> So the masterUrl is reachable/accessible so far as I am able to tell....
>>>
>>> Thanks,
>>>
>>> - Bill
>>>
>>> --------------------------------------------------
>>> From: "TCK" <moonwatcher32329@gmail.com>
>>> Sent: Monday, December 07, 2009 1:50 PM
>>> To: <solr-user@lucene.apache.org>
>>> Subject: Re: Exception encountered during replication on slave....Any
>>> clues?
>>>
>>>> are you missing the port number in the master's url ?
>>>>
>>>> -tck
>>>>
>>>>
>>>>
>>>> On Mon, Dec 7, 2009 at 4:44 PM, William Pierce
>>>> <evalsinca@hotmail.com>wrote:
>>>>
>>>>> Folks:
>>>>>
>>>>> I am seeing this exception in my logs that is causing my replication
>>>>> to
>>>>> fail.    I start with  a clean slate (empty data directory).  I index
>>>>> the
>>>>> data on the postingsmaster using the dataimport handler and it
>>>>> succeeds.
>>>>>  When the replication slave attempts to replicate it encounters this
>>>>> error.
>>>>>
>>>>> Dec 7, 2009 9:20:00 PM org.apache.solr.handler.SnapPuller
>>>>> fetchLatestIndex
>>>>> SEVERE: Master at: http://localhost/postingsmaster/replication is not
>>>>> available. Index fetch failed. Exception: Invalid version or the data
>>>>> in
>>>>> not
>>>>> in 'javabin' format
>>>>>
>>>>> Any clues as to what I should look for to debug this further?
>>>>>
>>>>> Replication is enabled as follows:
>>>>>
>>>>> The postingsmaster solrconfig.xml looks as follows:
>>>>>
>>>>> <requestHandler name="/replication" class="solr.ReplicationHandler"
>
>>>>>   <lst name="master">
>>>>>     <!--Replicate on 'optimize' it can also be  'commit' -->
>>>>>     <str name="replicateAfter">commit</str>
>>>>>     <!--If configuration files need to be replicated give the names
>>>>> here
>>>>> .
>>>>> comma separated -->
>>>>>     <str name="confFiles"></str>
>>>>>   </lst>
>>>>>  </requestHandler>
>>>>>
>>>>> The postings slave solrconfig.xml looks as follows:
>>>>>
>>>>> <requestHandler name="/replication" class="solr.ReplicationHandler"
>
>>>>>   <lst name="slave">
>>>>>       <!--fully qualified url for the replication handler of
>>>>> master -->
>>>>>       <str
>>>>> name="masterUrl">http://localhost/postingsmaster/replication
>>>>> </str>
>>>>>       <!--Interval in which the slave should poll master .Format is
>>>>> HH:mm:ss . If this is absent slave does not poll automatically.
>>>>>        But a snappull can be triggered from the admin or the http API
>>>>> -->
>>>>>       <str name="pollInterval">00:05:00</str>
>>>>>    </lst>
>>>>>  </requestHandler>
>>>>>
>>>>>
>>>>> Thanks,
>>>>>
>>>>> - Bill
>>>>>
>>>>>
>>>>>
>>>>
>>>
>>
>
>
>
> -- 
> -----------------------------------------------------
> Noble Paul | Systems Architect| AOL | http://aol.com
> 

Mime
View raw message