lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lance Norskog <goks...@gmail.com>
Subject Re: Solr Drupal module problem
Date Fri, 15 Jan 2010 00:20:22 GMT
The situation is apparently that the latest Drupal requires Solr 1.4
but Debian does not have a Solr 1.4 product. Can you use an earlier
Drupal Solr package?

If you want to backport the current Drupal Solr package to Solr 1.3,
changing the Trie fields to 'sint' etc. might work.

You don't have to used the "source code" itself to use the 1.4 solr.
There is an official release with binaries.

On Thu, Jan 14, 2010 at 3:21 PM, David Stuart
<david.stuart@progressivealliance.co.uk> wrote:
> Hi,
>
> The Drupal Solr Module will work with both Solr 1.3 and 1.4
> I currently have client installations using both these versions with Drupal (verison
5 and 6 )
>
> Regards,
>
> Dave
>
>
> On 14 Jan 2010, at 23:08, Otis Gospodnetic wrote:
>
>> You may want to ask on Drupal's mailing lists.  I hear about Drupal and Solr constantly,
I can't imagine them not having Solr 1.4 support, esp. if you say their configs contain referenes
to things that are in Solr 1.4.0.
>>
>> Otis
>> --
>> Sematext -- http://sematext.com/ -- Solr - Lucene - Nutch
>>
>>
>>
>> ----- Original Message ----
>>> From: reallove <thereallove@gmail.com>
>>> To: solr-user@lucene.apache.org
>>> Sent: Thu, January 14, 2010 5:54:55 PM
>>> Subject: Re: Solr Drupal module problem
>>>
>>>
>>> Hello,
>>> Thanks for the answer.
>>> Unfortunately, in the Debian repositories, even in testing, latest Solr
>>> version is 1.3.0 . Can I use that for the Drupal module to work ? I highly
>>> prefer to use the Debian repositories instead the source code.
>>> Thank you.
>>>
>>>
>>> Otis Gospodnetic wrote:
>>>>
>>>> Hi,
>>>>
>>>> Solr 1.2.0 didn't have TrieIntField.
>>>> Use the latest Solr - Solr 1.4.0
>>>>
>>>> Otis
>>>> --
>>>> Sematext -- http://sematext.com/ -- Solr - Lucene - Nutch
>>>>
>>>>
>>>>
>>>> ----- Original Message ----
>>>>> From: reallove
>>>>> To: solr-user@lucene.apache.org
>>>>> Sent: Thu, January 14, 2010 5:43:23 PM
>>>>> Subject: Solr Drupal module problem
>>>>>
>>>>>
>>>>> Hello,
>>>>> System : Debian 5.0
>>>>> Java , tomcat & solr installed from the repositories.
>>>>> Java version 1.6_12 , tomcat 5.5 and solr 1.2.0 .
>>>>> I am trying to use the schema.xml and the solrconfig.xml from the Drupal
>>>>> module, but they fail to work.
>>>>> The error I am getting is :
>>>>> Error loading class 'solr.TrieIntField' .
>>>>> How can I fix this ?
>>>>> Thank you !
>>>>> --
>>>>> View this message in context:
>>>>> http://old.nabble.com/Solr-Drupal-module-problem-tp27169365p27169365.html
>>>>> Sent from the Solr - User mailing list archive at Nabble.com.
>>>>
>>>>
>>>>
>>>
>>> --
>>> View this message in context:
>>> http://old.nabble.com/Solr-Drupal-module-problem-tp27169365p27169511.html
>>> Sent from the Solr - User mailing list archive at Nabble.com.
>>
>
>



-- 
Lance Norskog
goksron@gmail.com

Mime
View raw message