lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Conover <scono...@gmail.com>
Subject solr blocking on commit
Date Tue, 19 Jan 2010 22:57:44 GMT
I'm using latest solr 1.4 with java 1.6 on linux.  I have a 3M
document index that's 10+GB.  We currently give solr 12GB of ram to
play in and our machine has 32GB total.

We're seeing a problem where solr blocks during commit - it won't
server /select requests - in some cases for more than 15-30 seconds.
We'd like to somehow configure things such that there's no
interruption in /select service.

I've tried tweaking many parts of solrconfig (based on searches of
this mailing list): playing with the lock, with autowarming (including
shutting it off), max searchers, etc.  I've tried asynchronous commits
(waitSearcher=false and waitFlush=false).  The problem won't go away.
I run a fair amount of /select load at solr and even when it doesn't
take 20 seconds to commit, I definitely see pauses in the log when
commits are in progress.

I have this sense that I'm just missing something obvious (?)

Regards,
Steve

Mime
View raw message