lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Wang <aw...@crossview.com>
Subject Re: Weird Behavior When Querying Field of Type String
Date Thu, 13 May 2010 02:31:17 GMT
Found the problem! It's because all the values in productType field have trailing spaces in
it like this:  "ProductBean     ". Thanks Hoss for your suggestion of using Luke query which
exposed the problem.

You guys are awesome!

Thanks,

Alex

On May 12, 2010, at 10:12 PM, Alex Wang wrote:

Sorry please discard my query results here, because I was playing with the field type and
changed it to "text" from "string" and forgot to change it back. I will change it back to
"string" and post the query results shortly.

I apologize for the careless mistake.

Thanks,

Alex

On May 12, 2010, at 10:04 PM, Alex Wang wrote:

Thanks Hoss. Please see the query results as follows:

: <result name="response" numFound="0" start="0"/>
: <lst name="debug">
:  <lst name="queryBoosting">
:   <str name="q">productType:ProductBean</str>
:   <null name="match"/>
:  </lst>

...can you please disable the QueryElevationComponent and see if that
changes things?

:  <str name="parsedquery_toString">productType:ProductBean</str>

What are the numFound values for these queries? (both with and w/o
QueryElevationComponent) ...

With QueryElevationComponent enabled, the following query found 714 docs, with it disabled,
it also returned 714 docs.

 /admin/select?q=productType:[*+TO+*]&rows=0

With QueryElevationComponent enabled, the following query found 714 docs, with it disabled,
 it returned 714 docs as well.



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message