lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <otis_gospodne...@yahoo.com>
Subject Re: solr indexing takes a long time and is not reponsive to abort command
Date Fri, 18 Jun 2010 21:39:32 GMT
DIH has a UI in Solr Admin that will show you the status of the indexing process.  Not sure
if you can see that in your Solr or not.

 

Otis
----
Sematext :: http://sematext.com/ :: Solr - Lucene - Nutch
Lucene ecosystem search :: http://search-lucene.com/



----- Original Message ----
> From: Ya-Wen Hsu <yhsu@eline.com>
> To: "solr-user@lucene.apache.org" <solr-user@lucene.apache.org>
> Sent: Fri, June 18, 2010 4:28:03 PM
> Subject: RE: solr indexing takes a long time and is not reponsive to abort command
> 
> Sorry if you received duplicate email from me. 

I checked the log, there 
> is no error in the log and no write-lock message in the log. Where else can I 
> check for more information? Can I see if any query is running? 

I finally 
> killed the process and run it again. This situation happened couple times in our 
> production and qa environment. It usually works after we kill and restart the 
> process. However, we would like to figure out what happen in the first place. 
> Thanks!

Wen
-----Original Message-----
From: Peter Karich 
> [mailto:
> href="mailto:peathal@yahoo.de">peathal@yahoo.de] 
Sent: Friday, June 18, 
> 2010 1:04 PM
To: 
> href="mailto:solr-user@lucene.apache.org">solr-user@lucene.apache.org
Subject: 
> Re: solr indexing takes a long time and is not reponsive to abort 
> command

Did you kill the process or does a reload help afterwards?
Did 
> you look into the logs? Are there errors saying sth. of a 
> write-lock?

Peter.

> Hi,
>
> I have multi-core solr 
> setup. All cores finished indexing in reasonable time but one. I look at the 
> dataimport info for the one that's hanging. The process is still in busy state 
> but no requests made or rows fetched. The database side just showed the process 
> is waiting for future command and is doing nothing. The attempt to abort the 
> process doesn't really work. Does anyone know what's happening here? 
> Thanks!
>
> Wen

Mime
View raw message