lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Zhang <macromars...@gmail.com>
Subject Re: Field missing when use distributed search + dismax
Date Wed, 23 Jun 2010 08:11:45 GMT
Hi. All.

I found more about fields missing things.
I tried the default distributed search example which configured 2 instances,
one on 8983 and another on 7574.
When I try search with standard query handler, the result fields are all
right.
When I search with the deafult dismax, some fields disappeared. Not sure
why.

Can anyone test this and confirm the reason?

Thanks.
Regards.


On Wed, Jun 23, 2010 at 2:50 PM, Scott Zhang <macromarship@gmail.com> wrote:

> Hi. Lance.
>
> Thanks for replying.
>
> Yes. I especially checked the schema.xml and did another simple test.
> The broker is running on localhost:7499/solr.  A solr instance is running
> on localhost:7498/solr. For this test, I only use these 2 instances. 7499's
> index is empty. 7498 has 12 documents in index. I copied the schema.xml from
> 7498 to 7499 before test.
> 1. http://localhost:7498/solr/select
> I get:
> .....
> result name="response" numFound="12" start="0">
> -
> <doc>
> <str name="id">gppost_6179</str>
> <str name="type">gppost</str>
> </doc>
> .....
>
> 2. http://localhost:7499/solr/select
> I get:
> <result name="response" numFound="0" start="0"/>
>
> 3. http://localhost:7499/solr/select?shards=localhost:7498/solr
> I get:
> <result name="response" numFound="12" start="0">
> -
> <doc>
> <str name="id">gppost_6179</str>
> </doc>
> -
> <doc>
> <str name="id">gppost_6282</str>
> </doc>
>
> So strange!
>
> I then checked with standard searchhandler.
> 1. http://localhost:7499/solr/select?shards=localhost:7498/solr&q=marship
> <result name="response" numFound="1" start="0">
> -
> <doc>
> <str name="id">member_marship11</str>
> <str name="type">member</str>
> <date name="date">2010-01-21T00:00:00Z</date>
> </doc>
> </result>
>
> And 2.
> http://localhost:7499/solr/select?shards=localhost:7498/solr&q=marship&qt=dismax
> result name="response" numFound="1" start="0">
> -
> <doc>
> <str name="id">member_marship11</str>
> </doc>
> </result>
>
> So strange!
>
>
> On Wed, Jun 23, 2010 at 11:12 AM, Lance Norskog <goksron@gmail.com> wrote:
>
>> Do all of the Solr instances, including the broker, use the same
>> schema.xml?
>>
>> On 6/22/10, Scott Zhang <macromarship@gmail.com> wrote:
>> > Hi. All.
>> >    I was using distributed search over 30 solr instance, the previous
>> one
>> > was using the standard query handler. And the result was returned
>> correctly.
>> > each result has 2 fields. "ID" and "type".
>> >    Today I want to use search withk dismax, I tried search with each
>> > instance with dismax. It works correctly, return "ID" and "type" for
>> each
>> > result. The strange thing is when I
>> > use distributed search, the result only have "ID". The field "type"
>> > disappeared. I need that "type" to know what the "ID" refer to. Why solr
>> > "eat" my "type"?
>> >
>> >
>> > Thanks.
>> > Regards.
>> > Scott
>> >
>>
>>
>> --
>> Lance Norskog
>> goksron@gmail.com
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message