lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: Indexing Problem with SOLR multicore
Date Tue, 15 Jun 2010 00:33:45 GMT

I can't think of any way this could happen -- can you provide some more 
detials on what example you are doing, and hat you are doing to observe 
the problem?

In particular:
  * what do each of your DIH config files look like?
  * what URLs are you using to trigger DIH imports?
  * how are you checking your document counts?
  * what URLs are you querying to see the results? 
    - what results do you get from these URLs before you stop/start the 
      server that look correct?  
    - what results do you get after the stop/start thta are incorrect? 


: Hi,
:           I am using SOLR with Tomcat server. I have configured two
: multicore inside the SOLR home directory. The solr.xml file looks like 
: 
: <solr persistent="true" sharedLib="lib">
:   <cores adminPath="/admin/cores">
:     <core name="MyTestCore1" instanceDir="MyTestCore1"
: dataDir="MyTestCore1/data" />
:     <core name="MyTestCore2" instanceDir="MyTestCore2"
: dataDir="MyTestCore2/data" />
:   </cores>
: </solr> 
: 
: I am also using DIH to upload the data in these two cores separately &
: document count in these two core is different. However whenever I restart
: the tomcat server my document count in these two core show the same. Also
: both the core exits but whenever I tried to search the data in any core it
: returns me data from different core.
: 
: E.g. If I tried to search the data in MyTestCore1 core then solr returns the
: result from MyTestCore2 core (this is a problem) & If I tried to search the
: data in MyTestCore2 core then solr returns the data from MyTestCore2 core
: (which is fine) OR some time vice-versa   happens...
: 
: Now if I reindex the data in MyTestCore1 core using "Full data-import with
: cleanup" then problem gets sort out. but comes gaing if I restart my tomcat
: server.
: 
: Is there any issue with my core configuration? Please help....
: 
: 
: Thanks,
: Siddharth
: 
: 
: 
: -- 
: View this message in context: http://lucene.472066.n3.nabble.com/Indexing-Problem-with-SOLR-multicore-tp884745p884745.html
: Sent from the Solr - User mailing list archive at Nabble.com.
: 



-Hoss


Mime
View raw message