lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Moises Muratalla <...@tonesoft.com>
Subject Re: incomplete/missing results
Date Fri, 02 Jul 2010 22:47:50 GMT
here is some more info

I added this line

<field name="pts_info">
03320001   Travel Germany Arrive next day
</field>

It finds the "03320001" but none of the tokens on the rest of the line

Here are the definitions from the schema

<field name="pts_info" type="text" indexed="true" stored="true"
multiValued="true"/>

    <fieldType name="text" class="solr.TextField"
positionIncrementGap="100">
      <analyzer type="index">
        <tokenizer class="solr.WhitespaceTokenizerFactory"/>


<field name="all" type="text" indexed="true" stored="false"
multiValued="true"/>

<defaultSearchField>all</defaultSearchField>

   <copyField source="pts_info" dest="all"/>
   <copyField source="asm_source" dest="all"/>


On Fri, Jul 2, 2010 at 3:23 PM, Moises Muratalla <mmu@tonesoft.com> wrote:

> I posted some plain ASCII text files using the post.jar in the exampledocs
> directory.
>
> My queries work mostly.
>
> One recent problem: I search for "germany", it only returns 9 results, when
> there are actually 10.
>
> Would the schema help? I didn't really modify the solrconfig file
>
>
> On Thu, Jul 1, 2010 at 9:33 PM, Erik Hatcher <erik.hatcher@gmail.com>wrote:
>
>> Please provide us some details.  What and how did you index?   What
>> request did you make to Solr?
>>
>>        Erik
>>
>>
>> On Jul 1, 2010, at 5:56 PM, Moises Muratalla wrote:
>>
>>  I am getting incomplete search results with solr 1.4.0.
>>>
>>> Any suggestions on how to fix or debug this?
>>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message