lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Joiner <thomas.b.joi...@gmail.com>
Subject Re: Having problems with the java api in 1.4.0
Date Tue, 24 Aug 2010 16:23:31 GMT
Is there any reason you aren't using http://wiki.apache.org/solr/Solrj to
interact with Solr?

On Tue, Aug 24, 2010 at 11:12 AM, Liz Sommers <lizsworks@gmail.com> wrote:

> I am very new to the solr/lucene world.  I am using solr 1.4.0 and cannot
> move to 1.4.1.
>
> I have to index about 50 fields for each document, these fields are already
> in key/value pairs by the time I get to my index methods.  I was able to
> index them with lucene without any problem, but found that I could not then
> read the indexes with solr/admin.  So, I decided to use Solr for my
> indexing.
>
> The error I am currently getting is
> java.lang.RuntimeException: Can't find resource 'synonyms.txt' in classpath
> or 'solr/conf'/'
>
> This exception is being thrown by SolrResourceLoader.openResource(line
> 260).
> which is called by IndexSchema<init> (line 102)
>
> My code that leads up to this follows:
>
> <code>
> String path = "c:/swdev/apache-solr-1.4.0/IDW"
> SolrConfig cfg new SolrConfig(path + "/solr/conf/solrconfig.xml");
> schema = new IndexSchema(cfg,path + "/solr/conf/schema.xml",null);
>
> </code>
>
> This also fails if I use
> schema = new IndexSchema(cfg,"schema.xml",null);
>
>
> Any help would be greatly appreciated.
>
> Thank you
>
> Liz Sommers
> lizsworks@gmail.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message