lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank A <fsa...@gmail.com>
Subject Help Debugging Delta Query
Date Wed, 18 Aug 2010 14:08:26 GMT
Hi,

I'm trying to use a delta query to update a specific entity by its
primary key.  The URL I'm using is:

http://localhost:8080/solr/core2/dataimport?command=delta-import&did=5&commit=true&debug=true

Where 5 is the PK.

In my db config I have:

            <entity name="place"
            	query="select OurID,Name,City,State,lat,lng,cost from place"
                deltaQuery="select OurID from place where OurID=
'${dataimporter.request.did}'"
                deltaImportQuery="select
OurID,Name,City,State,lat,lng,cost from place where
OurID='${dataimporter.delta.id}'"
                >

When I run the URL above I see the following results:

<response>
<lst name="responseHeader">
<int name="status">0</int>
<int name="QTime">0</int>
</lst>
<lst name="initArgs
<lst name="defaults">
<str name="config">db-data-config.xml</str>
</lst>
</lst>
<str name="command">delta-import</str>
<str name="status">idle</str>
<str name="importResponse"/>
<lst name="statusMessages">
<str name="Total Requests made to DataSource">2</str>
<str name="Total Rows Fetched">1</str>
<str name="Total Documents Skipped">0</str>
<str name="Delta Dump started">2010-08-18 10:06:17</str>
<str name="Identifying Delta">2010-08-18 10:06:17</str>
<str name="Deltas Obtained">2010-08-18 10:06:17</str>
<str name="Building documents">2010-08-18 10:06:17</str>
<str name="Total Changed Documents">1</str>
<str name="Total Documents Processed">0</str>
<str name="Time taken ">0:0:0.32</str>
</lst>

</response>

It looks like its finding the row, but for some reason it's not
processing it - any ideas?

Thanks.
Frank

Mime
View raw message