lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Jelsma <markus.jel...@buyways.nl>
Subject RE: Autosuggest on PART of cityname
Date Thu, 19 Aug 2010 15:17:06 GMT
Hmm, you have only four documents in your index i guess? That would make sense because you
query for *:*. This technique doesn't rely on the found documents but the faceting engine
so you should include rows=0 in your query and the fl parameter is not required anymore. Also,
add facet=true to enable the faceting engine.

 

http://localhost:8983/solr/db/select/?wt=json&q=*:*&rows=0&facet=true&facet.field=city&facet.prefix=bost


 
-----Original message-----
From: PeterKerk <vetteparty@hotmail.com>
Sent: Thu 19-08-2010 17:11
To: solr-user@lucene.apache.org; 
Subject: RE: Autosuggest on PART of cityname


Ok, I now tried this:
http://localhost:8983/solr/db/select/?wt=json&indent=on&q=*:*&fl=city&facet.field=city&facet.prefix=Bost

Then I get:
{
"responseHeader":{
 "status":0,
 "QTime":0,
 "params":{
"fl":"city",
"indent":"on",
"q":"*:*",
"facet.prefix":"Bost",
"facet.field":"city",
"wt":"json"}},
"response":{"numFound":4,"start":0,"docs":[
{},
{},
{},
{}]
}}


So 4 total results, but I would have expected 1

What am I doing wrong?
-- 
View this message in context: http://lucene.472066.n3.nabble.com/Autosuggest-on-PART-of-cityname-tp1226088p1226571.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message