lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Gross <cogr...@gmail.com>
Subject Re: error sending a delete all request
Date Fri, 01 Oct 2010 13:37:50 GMT
Looking into it more, trying to issue a <delete><query>*:*</query></delete>
doesn't work on either index.  I went back to a different setup of tomcat
and solr (just one solr instance), and the command did run.  So I'm guessing
that I did misconfigure something, but I have no idea what.

Now I'm trying to set up a separate instance of tomcat/solr for my current
project (don't want to screw up the existing one) and having separate
issues...if anyone has run into something like this before and has any
pointers into why my multiple instances of solr aren't working right in
tomcat then please chime in!

Thanks!

-- Chris


On Thu, Sep 30, 2010 at 4:40 PM, Christopher Gross <cogross@gmail.com>wrote:

> I have also tried using SolrJ to hit my index, and I get this error:
>
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.useragent = Jakarta Commons-HttpClient/3.0
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.protocol.version = HTTP/1.1
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.connection-manager.class = class
> org.apache.commons.httpclient.SimpleHttpConnectionManager
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.protocol.cookie-policy = rfc2109
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.protocol.element-charset = US-ASCII
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.protocol.content-charset = ISO-8859-1
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.method.retry-handler =
> org.apache.commons.httpclient.DefaultHttpMethodRetryHandler@1a082e2
> 2010-09-30 16:23:14,406 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.dateparser.patterns = [EEE, dd MMM yyyy HH:mm:ss zzz, EEEE, dd-MMM-yy
> HH:mm:ss zzz, EEE MMM d HH:mm:ss yyyy, EEE, dd-MMM-yyyy HH:mm:ss z, EEE,
> dd-MMM-yyyy HH-mm-ss z, EEE, dd MMM yy HH:mm:ss z, EEE dd-MMM-yyyy HH:mm:ss
> z, EEE dd MMM yyyy HH:mm:ss z, EEE dd-MMM-yyyy HH-mm-ss z, EEE dd-MMM-yy
> HH:mm:ss z, EEE dd MMM yy HH:mm:ss z, EEE,dd-MMM-yy HH:mm:ss z,
> EEE,dd-MMM-yyyy HH:mm:ss z, EEE, dd-MM-yyyy HH:mm:ss z]
> 2010-09-30 16:23:14,421 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.connection-manager.max-per-host = {HostConfiguration[]=32}
> 2010-09-30 16:23:14,421 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.connection-manager.max-total = 128
> 2010-09-30 16:23:14,421 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.socket.timeout = 20000
> 2010-09-30 16:23:14,421 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.connection-manager.timeout = 40000
> 2010-09-30 16:23:14,453 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.connection-manager.max-per-host = {HostConfiguration[]=100}
> 2010-09-30 16:23:14,453 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.params.DefaultHttpParams - Set parameter
> http.connection-manager.max-total = 100
> 2010-09-30 16:23:14,484 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.MultiThreadedHttpConnectionManager -
> HttpConnectionManager.getConnection:  config = HostConfiguration[host=
> http://localhost:8080], timeout = 40000
> 2010-09-30 16:23:14,484 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.MultiThreadedHttpConnectionManager -
> Allocating new connection, hostConfig=HostConfiguration[host=
> http://localhost:8080]
> 2010-09-30 16:23:14,500 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.HttpConnection - Open connection to
> localhost:8080
> 2010-09-30 16:23:14,515 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.HttpMethodBase - Adding Host request header
> 2010-09-30 16:23:14,515 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.methods.EntityEnclosingMethod - Request body
> sent
> 2010-09-30 16:23:14,515 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.HttpMethodBase - Should close connection in
> response to directive: close
> 2010-09-30 16:23:14,515 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.HttpConnection - Releasing connection back to
> connection manager.
> 2010-09-30 16:23:14,515 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.MultiThreadedHttpConnectionManager - Freeing
> connection, hostConfig=HostConfiguration[host=http://localhost:8080]
> 2010-09-30 16:23:14,515 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.util.IdleConnectionHandler - Adding connection
> at: 1285878194515
> 2010-09-30 16:23:14,515 [pool-2-thread-1] DEBUG
> org.apache.commons.httpclient.MultiThreadedHttpConnectionManager - Notifying
> no-one, there are no waiting threads
> 2010-09-30 16:23:14,515 [pool-2-thread-1] WARN
> gov.dni.search.intelsync.exporter.SyncExporter -
> org.apache.solr.common.SolrException: Internal Server Error
>
> Internal Server Error
>
> request: http://localhost:8080/solr2/update?wt=xml&version=2.2
>         at
> org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:343)
>         at
> org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:183)
>         at
> org.apache.solr.client.solrj.request.UpdateRequest.process(UpdateRequest.java:217)
>         at
> org.apache.solr.client.solrj.SolrServer.deleteByQuery(SolrServer.java:101)
>         at
> gov.dni.search.intelsync.exporter.SolrExporter.dropIndex(SolrExporter.java:43)
>         at
> gov.dni.search.intelsync.iped.IpedClient.reindex(IpedClient.java:47)
>         at
> gov.dni.search.intelsync.common.SyncTargetReindexer.call(SyncTargetReindexer.java:27)
>         at
> gov.dni.search.intelsync.common.SyncTargetReindexer.call(SyncTargetReindexer.java:10)
>         at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
>         at java.util.concurrent.FutureTask.run(Unknown Source)
>         at java.util.concurrent.Executors$RunnableAdapter.call(Unknown
> Source)
>         at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
>         at java.util.concurrent.FutureTask.run(Unknown Source)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
> Source)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
> Source)
>         at java.lang.Thread.run(Unknown Source)
>
> I do have 2 solr indexes set up, did I do something wrong configuring them
> perhaps?  Code for my other index still runs.
>
> -- Chris
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message