lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: solr-user
Date Mon, 04 Oct 2010 12:27:15 GMT
I suspect you're not actually including the path to those jars.
SolrException should be in your solrj jar file. You can test this
by executing "jar -tf apacheBLAHBLAH.jar" which will dump
all the class names in the jar file. I'm assuming that you're
really including the version for the * in the solrj jar file here....

So I'd guess it's a classpath issue and you're not really including
what you think you are....

HTH
Erick

On Fri, Oct 1, 2010 at 11:28 PM, ankita shinde <ankitashinde002@gmail.com>wrote:

> ---------- Forwarded message ----------
> From: ankita shinde <ankitashinde002@gmail.com>
> Date: Sat, Oct 2, 2010 at 8:54 AM
> Subject: solr-user
> To: solr-user@lucene.apache.org
>
>
> hello,
>
> I am trying to use solrj for interfacing with solr. I am trying to run the
> SolrjTest example. I have included all the following  jar files-
>
>
>   - commons-codec-1.3.jar
>   - commons-fileupload-1.2.1.jar
>   - commons-httpclient-3.1.jar
>   - commons-io-1.4.jar
>   - geronimo-stax-api_1.0_spec-1.0.1.jar
>   - apache-solr-solrj-*.jar
>   - wstx-asl-3.2.7.jar
>   - slf4j-api-1.5.5.jar
>   - slf4j-simple-1.5.5.jar
>
>
>
>
>  But its giving me error as 'NoClassDefFoundError:
> org/apache/solr/client/solrj/SolrServerException'.
> Can anyone tell me where did i go wrong?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message