lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <otis_gospodne...@yahoo.com>
Subject Re: Indexing and Searching Chinese with SolrNet
Date Tue, 18 Jan 2011 18:39:16 GMT
Bing Li,

Go to your Solr Admin page and use the Analysis functionality there to enter 
some Chinese text and see how it's getting analyzed at index and at search 
time.  This will tell you what is (or isn't) going on.
Here it looks like you just defined index-time analysis, so you should see your 
index-time analysis look very different from your query-time analysis.

Otis
----
Sematext :: http://sematext.com/ :: Solr - Lucene - Nutch
Lucene ecosystem search :: http://search-lucene.com/



----- Original Message ----
> From: Bing Li <lblabs@gmail.com>
> To: solr-user@lucene.apache.org
> Sent: Tue, January 18, 2011 1:30:37 PM
> Subject: Indexing and Searching Chinese with SolrNet
> 
> Dear all,
> 
> After reading some pages on the Web, I created the index with  the following
> schema.
> 
> ......
>                  <fieldtype name="text"  class="solr.TextField"
> positionIncrementGap="100">
>                          <analyzer  type="index">
>                                   <tokenizer
> class="solr.ChineseTokenizerFactory"/>
>                           </analyzer>
>                  </fieldtype>
> ......
> 
> It must be correct, right? However, when  sending a query though SolrNet, no
> results are returned. Could you tell me  what the reason is?
> 
> Thanks,
> LB
> 

Mime
View raw message