lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bing Li <lbl...@gmail.com>
Subject Re: Indexing and Searching Chinese with SolrNet
Date Tue, 18 Jan 2011 18:59:05 GMT
Dear Jelsma,

My servlet container is Tomcat 7. I think it should accept Chinese
characters. But I am not sure how to configure it. From the console of
Tomcat, I saw that the Chinese characters in the query are not displayed
normally. However, it is fine in the Solr Admin page.

I am not sure either if SolrNet supports Chinese. If not, how can I interact
with Solr on .NET?

Thanks so much!
LB


On Wed, Jan 19, 2011 at 2:34 AM, Markus Jelsma
<markus.jelsma@openindex.io>wrote:

> Why creating two threads for the same problem? Anyway, is your servlet
> container capable of accepting UTF-8 in the URL? Also, is SolrNet capable
> of
> handling those characters? To confirm, try a tool like curl.
>
> > Dear all,
> >
> > After reading some pages on the Web, I created the index with the
> following
> > schema.
> >
> > ......
> >                 <fieldtype name="text" class="solr.TextField"
> > positionIncrementGap="100">
> >                         <analyzer type="index">
> >                                 <tokenizer
> > class="solr.ChineseTokenizerFactory"/>
> >                         </analyzer>
> >                 </fieldtype>
> > ......
> >
> > It must be correct, right? However, when sending a query though SolrNet,
> no
> > results are returned. Could you tell me what the reason is?
> >
> > Thanks,
> > LB
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message