lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Melanie Drake <melanie.dr...@gmail.com>
Subject wildcard search inconsistencies
Date Fri, 01 Apr 2011 15:47:06 GMT
I noticed an inconsistency in results when performing wildcard searches. 
When searching on variations of "conditional" the following results
occurred:

conditional - hits
conditional* - hits
conditi* - hits
condit* - hits
con*al - no hits
c?nditional - no hits
c*ld - hits (on a different word: "child")

I don't see an obvious pattern to when the wildcard searches work.

In a response to another post, I read that stemming will cause wildcard
searches to behave strangely.  I believe we may be using stemming, although
the only configuration I see is the list of words protected against stemming
defined in protwords.txt.

Also, I'm not sure if it's helpful, but I see a vague Solr error in my
server log (jboss) any time I perform a search (whether successful or not):
ERROR [STDERR]  org.apache.solr.core.SolrCore execute
INFO: [core0] webapp=null path=/select
params={q=condi*al&fq=url%3A%28%22%2F&fl=score&hl=true&hl.fragsize=50&hl.snippets=3}
hits=0 status=0 QTime=0

The developer who implemented our search solution is no longer with our
company, so I'm just looking for any information useful to investigate this
issue.  I apologize if I ommitted any necessary information.  Thanks!

--
View this message in context: http://lucene.472066.n3.nabble.com/wildcard-search-inconsistencies-tp2763787p2763787.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message