lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Demian Katz <demian.k...@villanova.edu>
Subject RE: Solr 3.1 ICU filters (error loading class)
Date Mon, 18 Apr 2011 19:36:49 GMT
Right, I placed my files relative to solr_home, not in it -- but obviously having a solr_home/lucene-libs
directory didn't do me any good. :-)

- Demian

> -----Original Message-----
> From: Jonathan Rochkind [mailto:rochkind@jhu.edu]
> Sent: Monday, April 18, 2011 1:46 PM
> To: solr-user@lucene.apache.org
> Cc: Demian Katz
> Subject: Re: Solr 3.1 ICU filters (error loading class)
> 
> I don't think you want to put them in solr_home, I think you want to
> put
> them in solr_home/lib/.  Or did you mean that's where you put them?
> 
> On 4/18/2011 1:31 PM, Demian Katz wrote:
> > Hello,
> >
> > I'm interested in trying out the new ICU features in Solr 3.1.
> However, when I attempt to set up a field type using
> solr.ICUTokenizerFactory and/or solr.ICUFoldingFilterFactory, Solr
> refuses to start up, issuing "Error loading class" exceptions.
> >
> > I did see the README.txt file that mentions lucene-libs/lucene-*.jar
> and lib/icu4j-*.jar.  I tried putting all of these files under my Solr
> home directory, but it made no difference.
> >
> > Is there some other .jar that I need to add to my library folder?  Am
> I doing something wrong with the known dependencies?  (This is the
> first time I've seen a lucene-libs directory, so I wasn't sure if that
> required some special configuration).  Any general troubleshooting
> advice for figuring out what is going wrong here?
> >
> > thanks,
> > Demian
> >

Mime
View raw message