lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Mortimer <...@flax.co.uk>
Subject Re: Highlighting not working
Date Thu, 07 Apr 2011 10:46:05 GMT
I guess what I'm asking is - can Solr highlight non-indexed fields?

Tom


On 7 April 2011 11:33, Tom Mortimer <tom@flax.co.uk> wrote:
> Hi,
>
> I'm having trouble getting highlighting to work for a large text
> field. This field can be in several languages, so I'm sending it to
> one of several fields configured appropriately (e.g. "cv_text_en") and
> then copying it to a common field for storage and display ("cv_text").
> The relevant fragment of schema.xml looks like:
>
>    <field name="cv_text_en" type="text_en" indexed="true"
> stored="false" termVectors="true" termPositions="true"/>
>    ...
>    <copyField source="cv_text_*" dest="cv_text" />
>    <field name="cv_text"       type="text"   indexed="false" stored="true" />
>
> At search time I can't get cv_text to be highlighted - it's returned
> in its entirety. Here's the relevant bit of solrconfig.xml (I'm
> qt="all" with the default request handler):
>
>  <requestHandler name="all" class="solr.SearchHandler" default="false">
>    <lst name="defaults">
>        <str name="echoParams">explicit</str>
>        <int name="rows">10</int>
>
>        <str name="df">cv_text_en</str>
>        <str name="df">cv_text_de</str>
>        ...
>
>        <str name="hl">on</str>
>        <str name="hl.fl">cv_text</str>
>
>     </lst>
>
> I've tried playing with other hl. parameters, but have had no luck so
> far. Any ideas?
>
> thanks,
> Tom
>

Mime
View raw message