lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marius van Zwijndregt <pionw...@gmail.com>
Subject Re: Solr 3.1 performance compared to 1.4.1
Date Mon, 11 Apr 2011 07:27:40 GMT
Hi Yonik !

Thanks for your reply.

I decided to switch to 3.1 and see if the performance would settle down
after building up a proper index. Looking at the average response time from
both installations i can see that 3.1 is now actually performing much better
than 1.4.1 (1.4.1 shows an average of 43ms, 3.1 shows 32ms)

My earlier test (with new keywords) now shows that 3.1 also outperforms
1.4.1 with keywords which have not yet been queried.

For the record, the tests are ran on ubuntu 10.04 (8GB ram, Quad core,
software raid 1). Ive given both installations a jvm with 1GB of ram. Ive
unpacked a new installation of 3.1 besides 1.4.1, and copied in the (in my
case) missing parts of configuration (dataimporter, sql xml config and
schema additions).

Cheers !

Marius

2011/4/10 Yonik Seeley <yonik@lucidimagination.com>

> On Fri, Apr 8, 2011 at 9:53 AM, Marius van Zwijndregt
> <pionware@gmail.com> wrote:
> > Hello !
> >
> > I'm new to the list, have been using SOLR for roughly 6 months and love
> it.
> >
> > Currently i'm setting up a 3.1 installation, next to a 1.4.1 installation
> > (Ubuntu server, same JVM params). I have copied the configuration from
> 1.4.1
> > to the 3.1.
> > Both version are running fine, but one thing ive noticed, is that the
> QTime
> > on 3.1, is much slower for initial searches than on the (currently
> > production) 1.4.1 installation.
> >
> > For example:
> >
> > Searching with 3.1; http://mysite:9983/solr/select?q=grasmaaier: QTime
> > returns 371
> > Searching with 1.4.1: http://mysite:8983/solr/select?q=grasmaaier: QTime
> > returns 59
> >
> > Using debugQuery=true, i can see that the main time is spend in the query
> > component itself (org.apache.solr.handler.component.QueryComponent).
> >
> > Can someone explain this, and how can i analyze this further ? Does it
> take
> > time to build up a decent query, so could i switch to 3.1 without having
> to
> > worry ?
>
> Thanks for the report... there's no reason that anything should really
> be much slower, so it would be great to get to the bottom of this!
>
> Is this using the same index as the 1.4.1 server, or did you rebuild it?
>
> Are there any other query parameters (that are perhaps added by
> default, like faceting or anything else that could take up time) or is
> this truly just a term query?
>
> What platform are you on?  I believe the Lucene Directory
> implementation now tries to be smarter (compared to lucene 2.9) about
> picking the best default (but it may not be working out for you for
> some reason).
>
> -Yonik
> http://www.lucenerevolution.org -- Lucene/Solr User Conference, May
> 25-26, San Francisco
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message