lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <s...@elyograg.org>
Subject Re: Trouble configuring multicore / accessing admin page
Date Wed, 28 Sep 2011 20:03:04 GMT
On 9/28/2011 1:40 PM, Joshua Miller wrote:
> I am trying to get SOLR working with multiple cores and have a problem accessing the
admin page once I configure multiple cores.
>
> Problem:
> When accessing the admin page via http://solrhost:8080/solr/admin, I get a 404, "missing
core name in path".
>
> Question:  when using the multicore option, is the standard admin page still available?

When you enable multiple cores, the URL syntax becomes a little 
different.  On 1.4.1 and 3.2.0, I ran into a problem where the trailing 
/ is required on this URL, but that problem seems to be fixed in 3.4.0:

http://host:port/solr/corename/admin/

If you put a defaultCoreName="somecore" into the <cores> tag in 
solr.xml, the original /solr/admin URL should work as well.  I just 
tried it on Solr 3.4.0 and it does work.  According to the wiki, it 
should work in 1.4 as well.  I don't have a 1.4.1 server any more, so I 
can't verify that.

http://wiki.apache.org/solr/CoreAdmin#cores

Thanks,
Shawn


Mime
View raw message