lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Lucene version error after migrating to Solr 3.5
Date Thu, 08 Dec 2011 20:11:14 GMT
OK, migrating to Solr 3.5 from what?

But what it *looks* like is that you are running a 3.5
config (see luceneMatchVersion in solrconfig.xml)
against a 3.3 Solr installation. In other words
it might be that you're running the old code against
a new schema.

But I'll freely admit that the luceneMatchVersion stuff
confuses the heck out of me.

note that going the other way should be fine, that is using
a solrconfig.xml with a match of 33 with a 3.5 executable....

Best
Erick

On Thu, Dec 8, 2011 at 5:39 AM, Kissue Kissue <kissuenow@gmail.com> wrote:
> After migrating to Solr 3.5, i restart tomcat and i get the error below.
> Any ideas what i am doing wrong?
>
> SEVERE: org.apache.solr.common.SolrException: Invalid luceneMatchVersion
> 'LUCENE_35', valid values are: [LUCENE_20, LUCENE_21, LUCENE_22, LU
> CENE_23, LUCENE_24, LUCENE_29, LUCENE_30, LUCENE_31, LUCENE_32, LUCENE_33,
> LUCENE_CURRENT] or a string in format 'V.V'
>        at
> org.apache.solr.core.Config.parseLuceneVersionString(Config.java:353)
>        at org.apache.solr.core.Config.getLuceneVersion(Config.java:337)
>        at org.apache.solr.core.SolrConfig.<init>(SolrConfig.java:133)
>        at org.apache.solr.core.CoreContainer.create(CoreContainer.java:435)
>        at org.apache.solr.core.CoreContainer.load(CoreContainer.java:316)
>        at org.apache.solr.core.CoreContainer.load(CoreContainer.java:207)
>        at
> org.apache.solr.core.CoreContainer$Initializer.initialize(CoreContainer.java:130)
>        at
> org.apache.solr.servlet.SolrDispatchFilter.init(SolrDispatchFilter.java:94)
>        at
> org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:295)
>        at
> org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFilterConfig.java:422)
>        at
> org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:115)
>        at
> org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4001)
>        at
> org.apache.catalina.core.StandardContext.start(StandardContext.java:4651)
>        at
> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
>        at
> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
>        at
> org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546)
>        at
> org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:637)
>        at
> org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:563)
>        at
> org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:498)
>        at
> org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
>        at
> org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
>        at
> org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
>        at
> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
>        at
> org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
>        at
> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
>        at
> org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
>        at
> org.apache.catalina.core.StandardService.start(StandardService.java:519)
>        at
> org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
>        at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>        at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>        at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>        at java.lang.reflect.Method.invoke(Method.java:597)
>        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
>        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
> Caused by: java.lang.IllegalArgumentException: No enum const class
> org.apache.lucene.util.Version.LUCENE_35
>        at java.lang.Enum.valueOf(Enum.java:196)
>        at org.apache.lucene.util.Version.valueOf(Version.java:32)
>        at
> org.apache.solr.core.Config.parseLuceneVersionString(Config.java:351)
>        ... 34 more

Mime
View raw message