lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ZHANG Liang F <Liang.f.Zh...@alcatel-sbell.com.cn>
Subject Problem about range search
Date Mon, 09 Apr 2012 06:10:29 GMT
Hi,
I ran into a problem when trying range facet search. I had a schema define like this:
 <fields>
   <field name="title" type="string" indexed="true" stored="true"/>
   <field name="author" type="string" indexed="true" stored="true" />
   <field name="text" type="text" indexed="true" stored="true" />
   <field name="path" type="string" indexed="true" stored="true" />
   <field name="size" type="long" indexed="true" stored="true" />
   <field name="lastmodified" type="date" indexed="true" stored="true" />
 </fields>

I try to set up a range search on "size" field which stands for the size of a file. So I have
the following requestHandler config in solrconfig.xml:
  <str name="facet.range.other">after</str>
  <str name="facet.range">size</str>
  <int name="f.size.facet.range.start">0</int>
  <int name="f.size.facet.range.end">15728640</int><!-- around 15M -->
  <int name="f.size.facet.range.gap">3145728</int><!-- around 3M -->

But an error says:  Unable to range facet on field:size{type=long,properties=indexed,stored,omitNorms,omitTermFreqAndPositions}

It doesn't show any clue, and I also tried <long> tag, but got the same error.

Could you please help to suggest?

Thanks in advance!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message