lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Ramos Jardim <alexander.ramos.jar...@gmail.com>
Subject Re: Why this document does not match?
Date Tue, 10 Apr 2012 00:22:15 GMT
Sorry for the answer.

2012/3/29 Erick Erickson <erickerickson@gmail.com>

> Alexander:
>
> Your images were stripped by one of our mail servers, so there's not
> much we can see <G>...
>
> But guessing, you aren't searching the fields you think you are:
> itemNameSearch:fifa12
> becomes
> itemNameSearch:fifa defaultSearchField:12
>

That's exactly what's happening! Why does this happen?


>
> where defaultSearchField is defined in your schema.xml file.
> Try itemNameSearch:(fifa 12) or similar.
>
> Using debugQuery=on should show this in the "parsed_query" section if I'm
> right.
>
> If that doesn't help, maybe you can post your info again?
>
> <standard comment that this is really old Solr, are you sure you can't
> upgrade?>
>

this has been discussed a lot. And my customer's sysdamin accepted
upgrading to Solr 3.5 , but we won't be doing this in the next month.


>
> Best
> Erick
>
> On Wed, Mar 28, 2012 at 5:31 PM, Alexander Ramos Jardim
> <alexander.ramos.jardim@gmail.com> wrote:
> >
> > Hi,
> >
> > I have an old Solr 1.3 version running on an issue. I have a field
> configured in such a way that "fifa 12" and "fifa12" should match the same
> documents, as it can be seen in screenshot bellow.
> >
> >
> >
> >
> > When I run the query itemNameSearch:fifa12, I get the folowing result:
> >
> >
> >
> >
> > That seems okay. But I have the following document on the index:
> >
> >
> > As my field is defined, I expected the query to match this document.
> This is not what is happening. Does anyone have any idea on what is wrong?
> >
> >
> > --
> > Alexander Ramos Jardim
>



-- 
Alexander Ramos Jardim

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message